Degraded Service due to AWS outage
Incident Report for Truework
Resolved
This incident has been resolved.
Posted Nov 24, 2021 - 12:21 PST
Update
We're seeing recovery in our error rates, however, we'll continue monitoring until AWS closes their incident.
Posted Nov 24, 2021 - 12:00 PST
Monitoring
Due to an outage with our cloud services provider, certain operations, specifically the manipulation of PDFs, may be partially or completely unavailable. Other site functions remain operational.
Posted Nov 24, 2021 - 10:45 PST
This incident affected: Portal - Human Resources, Portal - Employees, Portal - Verifier, Truework API, and Main Website.