Planned Maintenance

Incident Report for Truework

Resolved

Maintenance window complete
Posted Apr 26, 2026 - 22:03 PDT

Identified

We will be performing scheduled maintenance on Sunday, April 26, 2026 from 8:00 – 10:00 PM PDT. During this time, you may experience temporary service interruptions or be unable to log in to the Truework platform. No action is required on your part — all services will resume automatically once maintenance is complete.
Posted Apr 26, 2026 - 19:38 PDT
This incident affected: Portal - Human Resources, Portal - Employees, Portal - Verifier, Truework API, and Encompass Integration.