Elevated Error Rates
Incident Report for Truework
Resolved
We've concluded our review and believe that all platform behavior should be back to normal.
Posted Oct 08, 2024 - 11:42 PDT
Monitoring
The underlying issue with our infrastructure provider has been resolved and operations should be mostly back to normal. We will continue monitoring to make sure there aren't any remaining issues.
Posted Oct 07, 2024 - 13:30 PDT
Update
We are continuing to investigate this issue.
Posted Oct 07, 2024 - 12:50 PDT
Investigating
We are aware of an incident impacting various Truework features. This incident stems from an underlying issue with our infrastructure provider. We are monitoring the situation.
Posted Oct 07, 2024 - 12:49 PDT
This incident affected: Portal - Human Resources, Portal - Employees, Portal - Verifier, Truework API, DUVS Report Retrieval Service, Encompass Integration, and Truework Sandbox.