Verification Requests not loading on user dashboard
Incident Report for Truework
Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 12:59 PST
Update
We are continuing to investigate this issue.
Posted Feb 13, 2020 - 12:59 PST
Investigating
We are currently investigating the issue.
Posted Feb 13, 2020 - 12:48 PST
This incident affected: Portal - Verifier.