Verifications are slow to resolve
Incident Report for Truework
Resolved
This incident has been resolved.
Posted Jun 27, 2022 - 10:42 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2022 - 22:37 PDT
Update
We are continuing to investigate this issue.
Posted Jun 26, 2022 - 21:32 PDT
Investigating
We are currently investigating this issue.
Posted Jun 26, 2022 - 21:31 PDT
This incident affected: Portal - Verifier and Truework API.