Payment error - unable to submit verifications / manage payment methods through the portal
Incident Report for Truework
Resolved
Our payment partner saw elevated errors From 20:10–20:54 UTC. This is now resolved.
Posted Apr 27, 2022 - 15:14 PDT
Monitoring
Our payment provider is seeing recovery. We are continuing to monitor the situation.
Posted Apr 27, 2022 - 14:36 PDT
Identified
We have an issue with our payment provider, causing errors during submissions through the portal, as well as adding/changing payment methods. We are working with the partner and monitoring this issue.
Posted Apr 27, 2022 - 13:58 PDT
This incident affected: Portal - Human Resources, Portal - Employees, Portal - Verifier, and Main Website.