Elevated HTTP response latency
Incident Report for Truework
Resolved
This incident has been resolved.
Posted Mar 23, 2022 - 09:28 PDT
Monitoring
We are working with our provider to correct the issue and we are seeing recovery. We will continue to closely monitor the situation.
Posted Mar 22, 2022 - 11:09 PDT
Identified
We are continuing our investigation into an infrastructure issue with one of our providers. We’ve mitigated most latency at this point, but are working to identify a root cause before we consider this issue resolved.
Posted Mar 22, 2022 - 10:06 PDT
Investigating
We're investigating an increase in latency to all HTTP endpoints.
Posted Mar 21, 2022 - 09:25 PDT
This incident affected: Portal - Human Resources, Portal - Employees, Portal - Verifier, Truework API, and Main Website.