Elevated Synchronous API Response Times and Time to Verify due to Partner and Cloud Services Outage
Incident Report for Truework
Resolved
All components are functioning normally, and we are now operating at full capacity.
Posted Dec 08, 2021 - 09:07 PST
Update
We have resolved issues with our payroll partner and are now waiting for further recovery from other service providers.
Posted Dec 07, 2021 - 17:01 PST
Update
Our payroll partner is continuing to have issues, as are a number of other services we rely upon. The root cause of all issues is an outage in a major cloud services provider. We're continuing to monitor the issue and will announce when we have a resolution.
Posted Dec 07, 2021 - 15:19 PST
Update
We have temporarily blocked requests to this partner, returning response times to normal, at the cost of reducing hit rate while the partner is down.
Posted Dec 07, 2021 - 08:57 PST
Monitoring
We have an issue with one of our payroll partners, causing synchronous requests to have elevated response times. We are working with the partner and monitoring this issue.
Posted Dec 07, 2021 - 08:20 PST
This incident affected: Truework API.