Encompass customers are receiving an error message saying they have an outdated version of their loan file
Incident Report for Truework
Resolved
This issue has been resolved.
Posted May 10, 2022 - 15:16 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 10, 2022 - 13:11 PDT
Identified
What happened:
When a Truework verification is ordered, Encompass customers are receiving a server error saying they have an outdated version of their loan file.

What caused it:
Truework launched the ability to automatically write back the D1C Ref Number for D1C-eligible reports to the Truework GSE Vendor field in Encompass last week. As part of this, Truework writes to the loan object in Encompass when we update this information. How Truework had built this was to write back the entire loan object as is to Encompass and add the D1C Ref Number if present as an extra field. But when Encompass receives the loan object, it thinks that the entire loan file has been updated, even though the information Truework is writing back is the same as what already existed. This was an implementation mistake by Truework. Because Encompass thinks the loan file has changed, when customers save the loan file, they are seeing an error message that they have an outdated version of their loan file.

The current workaround for the customer is to close and open Encompass, or log out and log back in to get rid of this error. The Truework order will be placed successfully.

What we're doing to fix:
Truework is in the process of deploying a change where we will not write to loan object if the report is not D1C-eligible, and will only write back to the specific Truework GSE Vendor field with the D1C Reference Number field if the verification report once completed is D1C-eligible. This will remove the server error that currently shows when a Truework report is ordered. There is nothing the customer needs to do to enable this.

Timeframe:
Fix will go in by end of day. Please let Truework know if this issue persists beyond end of day.
Posted May 10, 2022 - 13:09 PDT
This incident affected: Encompass Integration.